BeBits Information Developer Central Submit Application Your Account Web Links Contact Us
BeBits
Tseng Labs ET6000, ET6100 and ET6300 graphics driver
Talkback
 Go back to the Tseng Labs ET6000, ET6100 and ET6300 graphics driver page
 Post a new Talkback comment!
To memson
 By evgeniy - Posted on June 27, 2004 - 21:55:09   (#13084)
 Current version when comment was posted: 0.3
> It's definately an ET6000 - it works as such with XFree. It was purchased in 1997 and is definately a PC card. The only odd thing about it is that the BIOS on the card is called VIEWTOP, and has a large sticker on it. It might have been the PCI slot I put it in I guess? I don't know if that makes a difference. I don't have the info with me here, but I think it's called a "Twister"... there's more to that name, but I don't remember. Long time ago since I needed to ;-)

I'm not sure, but probably the following is right:
ViewTOP BP-ET6 is ET6000-based and ViewTOP Twister BP-ET6 is ET6100 based.
I told you your card is ET6000 when you gave me its vendor ID and device ID, but I forgot that ET6000 and ET6100 have both this values equal, they only differ by revision ID (revision ID of ET6000 is <0x70, revision ID of ET6100 is >=0x70) - my drivers know it. So your card can be "ET6100-based".

> IIRC, the serial debug output looked like it was going to use the card, but then it never went any further.

There is a probability it's not the driver fault.

> Are you willing to release to me the source?

No, I'm not. I'd like you to send me the messages of the debug output you got.

One more thing..
 By memson - Posted on June 17, 2004 - 12:15:37   (#12933)
 Current version when comment was posted: 0.3
IIRC, the serial debug output looked like it was going to use the card, but then it never went any further.

Are you willing to release to me the source? I'll debug it for you if you want...

Re: ET6000
 By memson - Posted on June 17, 2004 - 12:12:48   (#12932)
 Current version when comment was posted: 0.3
It's definately an ET6000 - it works as such with XFree. It was purchased in 1997 and is definately a PC card. The only odd thing about it is that the BIOS on the card is called VIEWTOP, and has a large sticker on it. It might have been the PCI slot I put it in I guess? I don't know if that makes a difference. I don't have the info with me here, but I think it's called a "Twister"... there's more to that name, but I don't remember. Long time ago since I needed to ;-)

I don't know if the BIOS is flashable? It's a very old card.

More to memson
 By evgeniy - Posted on June 17, 2004 - 04:13:44   (#12927)
 Current version when comment was posted: 0.3
The card you try to use should be manufactured to work on PC platform and not on some another platform, for example, Mac.

Reply to memson
 By evgeniy - Posted on June 17, 2004 - 04:02:28   (#12926)
 Current version when comment was posted: 0.3
> Okay, so I've now tried this card with the driver,
> and it's not working.
Please, describe the symptoms you saw.
I hope you were using the latest driver version?

> vendor ID is: 0x100c
> card id is: 3208
> Should the card work if that vendor/card ID. Card
> reports to be a "Tseng labs" card...
It is a card on ET6000. It should work if the card is for PCI bus (not VLB), although not necessarily - it might depend on card manufacturer.


Ah... non working card..
 By memson - Posted on June 4, 2004 - 21:05:31   (#12710)
 Current version when comment was posted: 0.3
Okay, so I've now tried this card with the driver, and it's not working.

vendor ID is: 0x100c
card id is: 3208

Should the card work if that vendor/card ID. Card reports to be a "Tseng labs" card...

RE: H-kon
 By memson - Posted on January 6, 2004 - 12:21:58   (#10388)
 Current version when comment was posted: 0.3
pretty sure my card is the same model as H-kon's. It's 4mb iirc anyway. I didn't get a chance to test yesterday because I was v. busy doing other stuff. But as I have already ripped open a Mac today to fiddle with RAM, I'll try to see if I get similar issues. I'll leave it on till it goes wrong or a week is over, whichever comes first.

Matt

Questions to H-kon
 By evgeniy - Posted on January 6, 2004 - 11:31:42   (#10384)
 Current version when comment was posted: 0.3
> After 2 days,
Do you mean 2 days without reboot?

> i have experienced some distortions when using the
> 0.2 version of the driver. Fonts are barely
> readable, although dragging a tracker window
> over the distortions clears it up.
Could you please describe the distortions? And would be great you to send me some screenshots.

> Colors fade a bit as well over time.
8o[ ]
Are you sure?
Are you sure it's not your monitor who is to blame?


Not so fast
 By H-kon - Posted on January 5, 2004 - 16:01:12   (#10356)
 Current version when comment was posted: 0.3
After 2 days, i have experienced some distortions when using the 0.2 version of the driver. Fonts are barely readable, although dragging a tracker window over the distortions clears it up. Colors fade a bit as well over time.

Using the same card on a Windows 95 machine with no problems.



0.2 Works great
 By H-kon - Posted on January 3, 2004 - 22:53:08   (#10323)
 Current version when comment was posted: 0.2
That was fast :D My 4MB ET6000 works great. much crisper than the Rage II i had before.

Thanks :)

ET6x00 with 4Mb owners are recommended to try version 0.2
 By evgeniy - Posted on January 3, 2004 - 12:26:59   (#10296)
 Current version when comment was posted: 0.2
Subj.



ET6000 4MB - No go
 By H-kon - Posted on January 3, 2004 - 03:35:45   (#10286)
 Current version when comment was posted: 0.1
Window decor is all pitched black. desktop is black, although icons and text displays in color. Fonts unreadable, except for icon text on desktop.

This is the ET6000, 4MB version (22a2T3634)

Sticker on the back says: A2165A2 ENL002 6CA00158



OBOS CVS
 By s_d - Posted on January 2, 2004 - 19:31:54   (#10283)
 Current version when comment was posted: 0.1
IMHO once this driver gets matured, it may be added with author's permissions to OBOS CVS:)
So it may be first (?) contribution to OBOS from russian developer.
Btw, also SIS sound driver from Syarzhuk Zharski has same potential

WOOHOO!!
 By memson - Posted on January 2, 2004 - 16:47:20   (#10278)
 Current version when comment was posted: 0.1
I have one of these (ET6000 iirc) in a box at work. It ran under BeOS in VESA mode fine, and I started to look at writing a driver (looked for source for Linux/XFree etc) but ran out of free time.

If this indeed works (wait till Monday...) I'll post some feedback.

Matt

 
The Green Board
  Recent Downloads  -  # 65
Total Downloads  -  # 435
Total Views  -  # 431
User Ratings  -  N/A
  Video Drivers
1.  BePodder - 9.73
2.  QEMU - 9.68
3.  ScummVM - 9.57
4.  VNCServer - 9.36
5.  Haiku AGP busm... - 9.35
6.  cpu_fix - 9.31
7.  vim6 - 9.31
8.  Beezer - 9.26
9.  HandBrake - 9.25
10.  BeeF - 9.25
1.  Ati Radeon G... - 45,498
2.  BeOS 5 Perso... - 40,514
3.  BePDF - 29,600
4.  Ensoniq Audi... - 21,695
5.  Realtek RTL8... - 21,259
6.  USB Joystick... - 18,100
7.  VLC Media Pl... - 17,064
8.  ATI Rage 128... - 14,107
9.  DOSBox - 13,129
10.  S3 Trio 64 v... - 11,672
You are not logged in.
 Login

 
Unless otherwise noted, everything is copyright © 1999-2013 Haikuware. All Rights Reserved.
For more legal trivia, take a gander at our
Legal Stuff page and our Privacy Statement.
Website Deisgn: NumbDesign